Действия с лекалами на экране (масштабирование, перемещение по экрану, совмещения, повороты) называются экранными операциями, так как производятся только на экране и не меняют информацию о лекале в памяти компьютера.
Кроме экранных, временных операций с лекалами, в меню экранных функций находятся обслуживающие команды (очистка экрана, отмена выбора) а также важные команды организации работы: вызов и удаление лекал с экрана, сохранение лекал, отмена действия.
Функции экранного меню вынесены в вертикальное кнопочное меню в левой части рабочего окна, а также в закладку ОКНО тестового меню программы:
Часть экранных операций с лекалами находится на нижней панели рабочего окна:
Работа в «Таблице размножения»
и в окне «Контроля разводки»
описаны отдельно.
Для вызова на экран лекала из базы, необходимо выбрать команду
в меню экранных функций (или выполнить пункты текстового меню «Предмет/ Работа с базой»). При этом на экран выходит окно «Работы с базой» со списком лекал.
Порядок действий в окне «Работы с базой» описан в отдельном разделе Порядок вызова лекал.
Для вызова второго экземпляра лекала необходимо:
На экран выходит второй экземпляр лекала. Работа с ним, а также с группами линий (кнопка
экранного меню) – это необходимое условие выполнения функций на совмещённых лекалах с дальнейшим их «Перестроением». Действия с безымянными копиями лекал не «перестраиваются»
Для удаления с экрана одного лекала, необходимо:
Можно также выполнить пункты текстового меню «Окно/ Убрать лекало с экрана».
Кнопка
- убрать с экрана только указанное лекало из группы,
- убрать всю группу лекал.
Для очистки экрана, удалив с него все лекала, необходимо:
При этом экран очищается от всех лекал, а вид кнопки меняется для функции восстановления
.
Для удаления всех лекал с экрана без сохранения, нужно выбрать команду
, одновременно удерживая клавишу <CTRL>.
1) При удалении лекал с экрана (
,
) выполняется автоматическое сохранение лекал в базу, если в программе включена настройка
(пункты текстового меню «Настройки/ Параметры программы», закладки ОБЩИЕ/ Конструктор)
2) Запрос на очистку экрана не выходит, если отключена настройка
(пункты текстового меню «Настройки/ Параметры программы», закладки ОБЩИЕ/ Конструктор)
При выполнении команды очистки экрана кнопка экранного меню
меняется, принимая вид
.
При выборе команды
экранного меню (или пунктов текстового меню «Окно/ Восстановить экран») возвращается последний очищенный экран с лекалами, в том числе и безымянными.
ВНИМАНИЕ! Возвращённые на экран лекала сохранены в таком виде в базе, если в программе включена настройка
(пункты текстового меню «Настройки/ Параметры программы», закладки ОБЩИЕ/ Конструктор).
1) Если удалить из базы лекало, находящееся на последнем очищенном экране, (кнопка окна «Работы с базой»
), то при восстановлении этого экрана вернутся все лекала, кроме удалённого, и выходит сообщение:
Такое же сообщение выходит, если на последнем очищенном экране находились безымянные лекала.
Они остаются при восстановлении экрана до тех пор, пока данная модель находится в рабочем окне.
2) Функция автоматически активизируется после операций с лекалами в окне «Работы с базой».
Для удаления лекала без сохранения в базе, необходимо:
Можно также выполнить пункты текстового меню «Окно/ Убрать лекало не сохраняя».
Лекало удаляется с экрана, при этом последние несохранённые действия с ним отменяются.
Функция имеет смысл только в режиме автоматического сохранения лекал при удалении с экрана, то есть, с включённой настройкой
(пункты текстового меню «Настройки/ Параметры программы», закладки ОБЩИЕ/ Конструктор).
Информация обо всех лекалах и моделях содержится в базе данных на сервере. Лекала, изменённые на экране, необходимо сохранить. Сохраненные лекала модели попадают в базу на сервере, и становится доступны для дальнейшей работы (например, в программе «Раскладчик»).
Чтобы сохранить все изменения в лекалах, необходимо нажать кнопку
в меню экранных функций (или выполнить пункты текстового меню «Окно/ Сохранить содержимое экрана в базе»).
При этом все лекала, находящиеся на экране (кроме безымянных лекал), сохранятся в базу данных.
Для сохранения одного лекала на экране, необходимо:
1) При удалении лекал с экрана командами экранного меню
лекала
автоматически сохраняются, если включена настройка
(пункты текстового меню «Настройки/ Параметры программы», закладки ОБЩИЕ/ Конструктор)
2) Сохранение лекал выполняется лишь при внесении изменений в лекало. То есть, при сохранении отслеживается состояние лекала, и если оно не изменялось, повторная запись в базу не производится.
Иногда для работы нужен не последний вид лекала в базе, а его прежнее состояние, Back-копия.
В программе создаётся Автоматическая и Ручная Back-копия, в зависимости от выбора настройки (пункты текстового меню «Настройки/ Параметры программы», закладка ОБЩИЕ\ Конструктор)
Автоматическая Back -копия – это предыдущий, предпоследний сохранённый вид лекала.
При сохранении лекал командой
, в базе остаётся ещё и предыдущее сохранение лекала.
Это состояние лекала и выходит на экран при вызове Back-копии.
При следующем сохранении лекала, Back-копия автоматически заменяется.
При сохранении командой
отслеживается состояние лекала, и если оно не изменялось, повторная запись в базу не производится. Поэтому, например, сохранив лекало и сразу удалив его с экрана (с включённым автосохранением), мы не теряем Back-копию.
Ручная Back-копия – это специально сохраненный вид лекала, нужный конструктору.
Команда сохранения
в данном режиме работает, но не меняет автоматически вид Back-копии.
Ручную Back -копию формирует сам конструктор, сохраняя в качестве Back -копии не предпоследний вид, а любое нужное состояние лекала, к которому при необходимости можно вернуться.
При следующем сохранении ручной Back-копии, предыдущий вариант Back-копия удаляется.
Для сохранения лекала с созданием ручной Back-копии, необходимо:
(пункты текстового меню «Настройки/ Параметры программы», закладка ОБЩИЕ\ Конструктор).
При этом включается кнопка
экранного меню, заблокированная в автоматическом режиме:
Можно также выполнить пункты меню «Окно/ Сохранить содержимое экрана в базе с Back-копией».
Запись лекал с созданием Back-копии
сохраняет любое состояние лекала, независимо от того, менялось ли оно. Это позволяет вызвать лекала первый раз на экран, и ещё не меняя их, сохранить эти лекала в качестве Back-копий для возможности возврата к исходному виду лекал.
Для сохранения всех лекал экрана с созданием Back-копий, необходимо выбрать данную команду
, удерживая клавишу клавиатуры <CTRL>
Таким образом, в режиме ручного создания Back-копии работает две команды сохранения:
Функция
- сохраняет лекало
Функция
- сохраняет лекало, но ещё и сохраняет это состояние как Back-копию
В режиме автоматического создания Back-копии работает одна команда сохранения:
Функция
- сохраняет лекало, автоматически оставляя предыдущее сохранение как Back-копию
Вызов Back-копии лекала на экран выполняется в окне «Работы с базой» (
- «Предмет/ Работа с базой») при включении опции
. Back-копию можно убрать с экрана не сохраняя (
) или сохранить вместо последнего вида лекала.
Действия с лекалами на экране можно отменить, выполнив функцию возврата действий – «Откат».
В экранном меню программы работает два вида откатов - Пошаговый и Экранный откат, а также функция Отмены возврата действия: Отмена
С помощью кнопки
меню экранных функций (или пунктов текстового меню «Окно/ Шаг назад»)
выполняется возврат последнего действия на экране – однократный шаг назад.
После действий с лекалом, команда отката активизируется, а после выполнения отката - вновь блокируется, до следующего изменения лекала. При этом выполняется откат экрана на один шаг назад.
Возможны два варианта работы данной функции, в зависимости от выбора настройки программы:
(пункты текстового меню «Настройка/ Параметры программы», закладка ОБЩИЕ/ Конструктор)
1)Выполняется отмена только изменений, модификаций лекала
2) Выполняется отмена и модификаций, и экранных операций (совмещений, поворотов, и т.д.).
В режиме отката «Модификации», при выполнении экранных операций (смещение, повороты, и др.) функция отката заблокирована. После модификации лекала, выполняется возврат и этого действия, и экранной функции, выполненной после данной модификации.
В режиме отката «Все» некоторые экранные команды «Масштабирование», «Организация экрана», и т.д. всё-таки не будут иметь откат.
1) При появлении на экране безымянных лекал, экранный откат блокируется!
Например, при создании безымянной копии лекала, при вызове макрокоманды, и т.п., функция отката будет заблокирована, и можно выполнять лишь пошаговый откат, указывая конкретные лекала.
2) При любом изменении состава лекал на экране, откат будет заблокирован (удаление лекал с экрана, вывод лекал на экран (вызов из базы, оцифровка, вызов макрокоманд, создание копий).
3) Используя функцию экранного отката можно, не теряя курсор текущей команды, отменить действие и выполнить его по-другому, с другими величинами (ошибка ввода данных, выбора элемента).
Для отмены последней команды (или нескольких последних команд) на лекале, необходимо:
Можно также выполнить пункты текстового меню «Окно/ Отменить последнюю команду».
Экранные операции (смещения, повороты, перегиб) не имеют отката, так как не меняют лекало.
В зависимости от настройки
(пункты текстового меню «Настройки/ Параметры программы», закладки ОБЩИЕ/ Конструктор), есть два режима работы:
1) При включении настройки пределом при откате служит последний сохранённый вид лекала (
- «Окно/ Сохранить содержимое экрана в базе»). То есть, можно пошагово отменить все модификации лекала, пока они не сохранены. Но после сохранения лекала функция отката будет заблокирована.
2) При отключении настройки пределом при откате является состояние вызова лекала на экран (
- «Окно/ Работа с базой»). Поэтому даже при многократном сохранении лекала в ходе работы, возможность возврата остаётся, вплоть до состояния вызова лекала из базы.
Для возврата отменённого ранее действия на лекале, необходимо:
Функция активна только после выполнения на лекале отката. По достижении предела отмены, функция будет заблокирована.
В программе есть возможность корректировать лекала отдельно в каждом размере разводки.
Операции с лекалами, контурами, участками, точками выполняются как со всей разводкой, так и с отдельными размерами. Это касается функций различных смещений, деформаций, поворотов, и т.п.
Но операции, меняющие структуру лекала (изменение параметров и числа контуров, участков, точек), работают со всей разводкой в любом режиме.
Режим работы с разводкой зависит от состояния экранных переключателей:
- режим работы с одним размером: Операции выполняются в одном выбранном размере.
- режим работы с частью размеров: Операции выполняются с частью размеров.
При выборе данного режима выходит окно, в котором отмечаются размеры для работы:
- режим работы со всей разводкой: Операции с лекалами выполняются во всех размерах.
Кнопка выбранного режима выделяется «птичкой»:
,
,
.
ВНИМАНИЕ! Операции, меняющие структуру лекала, работают со всей разводкой независимо от положения данного переключателя.Это ограничение защищает от создания некорректной разводки.
Но в окне «Контроля разводки» работа отдельно с каждым размером всё-таки разрешена во всех активных функциях, именно для возможности корректировать ошибки разводки.
При проверке сопряжения лекал можно подправить форму линии в каком-то одном размере с некорректной конфигурацией. Для этого необходимо:
- «Участок/ Произвольная деформация» и
- «Участок/ Сплайновая деформация участка»
Функцию уравнивания сторон вытачки можно выполнять только для части больших размеров разводки, если в малых размерах переда вытачки нет. Для этого необходимо:
работы (в данном примере - 108 и 112)
При работе с лекалами возникает необходимость менять масштаб изображения на экране.
Для этого используются функции программы, «Горячие клавиши», и колесо прокрутки мышки.
В меню экранных функций масштабирование представлено блоком команд:
Функция позволяет увеличить на весь экран определённую область, выделенную рамкой.
Для этого необходимо:
Можно также выполнить пункты текстового меню «Окно/ Масштаб/ Микроскоп».
При этом часть лекала, попавшая в выбранную область, увеличится на весь экран.
Выбрав кнопку
в меню экранных функций (или пункты текстового меню «Окно / Масштаб/ Показать всё»), можно увидеть все лекала, находящиеся на экране.
Выбрав кнопку
в меню экранных функций (или пункты текстового меню «Окно/ Масштаб/ Вернуть масштаб») можно после изменения масштаба вернуть предыдущий масштаб изображения.
Выбрав кнопку
в меню экранных функций (или пункты текстового меню «Окно/ Масштаб/ Уменьшить масштаб») можно постепенно уменьшать изображение (при каждом щелчке в кнопку).
Команды постепенного увеличения/ уменьшения изображения выполняются
также с помощью центрального колеса прокрутки мышки:
Такое масштабирование работает, не прекращая выполнение основной команды программы.
Выбрав кнопку
в меню экранных функций (или пункты текстового меню «Окно/ Масштаб/ Увеличить масштаб») можно постепенно увеличивать изображение (при каждом щелчке в кнопку).
Команды постепенного увеличения/ уменьшения изображения выполняются
также с помощью центрального колеса прокрутки мышки:
Такое масштабирование работает, не прекращая выполнение основной команды программы.
Если одно из нескольких лекал требуется показать на весь масштаб экрана, нужно:
Можно также выполнить пункты текстового меню « Окно/ Масштаб/ Лекало на экран».
Указать лекало на экране. При этом выбранное лекало выходит в центре, на весь экран.
Масштабирование 1:1
Для масштабирования экрана в натуральную величину, нужно выполнить пункты текстового меню «Окно/ Масштаб/ 1:1». Однако, точность масштаба зависит от экранных настроек данного монитора.
При вызове нескольких лекал на экран, они все расположены в центре, наложенными друг на друга.
Выбрав кнопку
в меню экранных функций (или пункты текстового меню «Окно/ Организовать экран»), можно расположить без наложений все лекала в масштабе экрана.
При этом лекала, временно повёрнутые функциями экранных совмещений, поворотов, симметричных разворотов, и т.д. возвращаются в исходное положение, в котором они хранятся в базе.
1) При выполнении команды, нажав и удерживая клавишу клавиатуры <ALT> одновременно с выбором функции
, организация лекал выполняется медленнее, но более оптимально. Это может быть важно, например, для формирования листов прорисовки лекал.
2) При выполнении команды, нажав и удерживая клавишу клавиатуры <CTRL> одновременно с выбором функции
, лекала сохранят свои экранные повороты.
Группы совмещённых лекал не разрушаются, но и не меняют своего места
на экране, а свободные лекала будут организованы вокруг них.
Выбрав кнопку
в меню экранных функций (или пункты текстового меню «Окно/ Организовать экран с учётом долевых») можно разложить все лекала на экране с одним направлением Долевой - так, как они будут выходить в программе «Раскладчик».
Поскольку это экранная операция, положение (сортировка) лекал в базе не меняется.
Функция не работает с группами Совмещённых лекал, при этом на экран выходит сообщение:
Разложив лекала на экране в удобном для себя порядке, можно сохранить это расположение лекал.
В дальнейшем лекала можно не раскладывать после вызова, а считывать их сохранённое положение с экранными совмещениями, поворотами, и т.п. Лекала на сохранённых экранах выходят в своём последнем состоянии в базе, с учётом внесённых изменений.
Для сохранения экрана необходимо:
Чтобы считать ранее сохранённый экран, необходимо:
При этом выходит экран лекал в том расположении, котором их сохранили.
1)Если включена настройка программы
(пункты текстового меню «Настройка/ Параметры программы», закладки ОБЩИЕ/ Конструктор), автоматически созданный лист на прорисовку конструкторских лекал (
- «Чертить/ Чертить») попадает в список сохранённых экранов. Это даёт возможность вызвать лист и внести изменение в задании на прорисовку.
При удалении листа прорисовок, он удаляется и в списке сохранённых экранов, но не наоборот.
2)Если удалить из базы лекало, находящееся на сохранённом экране (кнопка
окна «Работы с
базой»), то при считывании этого экрана есть все лекала, кроме удалённого, и выходит сообщение:
Такое же сообщение выходит, если на сохранённом экране находились безымянные лекала.
Они остаются при считывании экрана до тех пор, пока данная модель находится в рабочем окне.
Чтобы вызвать все или несколько размеров лекала на экран, необходимо:
Можно выполнить пункты меню «Окно/ Экранные операции с лекалом(ми)/ Вывести размеры».
- выбрать все размеры,
- исключить выбор всех размеров.
Чтобы отметить все размеры одного роста, нужно выбрать ячейку с названием этого роста,
Чтобы отметить все роста одного размера, нужно выбрать ячейку с названием этого размера.
При этом на экран выходит разводка лекал.
Чтобы вызвать сразу всю разводку без таблицы размеров, нужно указывать лекало, предварительно нажав и удерживая клавишу клавиатуры <CTRL>
При включении настройки вывода размеров в режиме «Экран» вывод разводки выполняется сразу для всех лекал экрана:
(пункты текстового меню «Настройка/ Параметры программы», закладки ОБЩИЕ/ Конструктор)
Чтобы убрать разводку с экрана, оставив базовый размер, нужно повторно выполнить функцию
, и сразу нажать кнопку ДА в таблице размеров, где по умолчанию выбрана ячейка базового размера.
Чтобы удалить сразу всю разводку без таблицы размеров, нужно указывать лекало, предварительно нажав и удерживая клавишу клавиатуры <CTRL>
(Быстро убрать разводку также можно, выбрав размер в окне прокрутки размеров на нижней панели).
1) При переходе в режим работы с одним размером (переключатель
в экранном меню), лекала можно перемещать из разводки (кнопка
в меню экранных функций).
При этом каждый размер становится отдельным лекалом, повторным экземпляром исходного лекала.
Если при удалении разводки выполнить команду
, удерживая клавишу клавиатуры <ALT>, все смещённые размеры лекала собираются в единую разводку. Иначе, при удалении разводки на одном из лекал, остальные экземпляры остаются на экране.
2) Для вызова размеров разводки в разных цветах, нужно включить цветовую настройку «Размеры»
(пункты текстового меню «Настройки \ Параметры программы», закладка ОБЩИЕ/ Конструктор)
3) При указании лекала с неполной разводкой, на экран выходит список недостающих размеров:
При этом на экран выходит разводка, состоящая из существующих размеров.
В этом случае вывод размеров на экран (кнопки
нижней панели) ограничен только существующими размерами, в том числе и для лекал с полной разводкой.
Функция позволяет временно совмещать разводку лекал в определённой точке. При повторном вызове разводка будет выглядеть в начальном виде. Для совмещения разводки необходимо:
Или выполнить пункты меню «Окно/ Экранные операции с лекалом/ Совместить разводку в точке».
Данная функция используется для просмотра разводки, либо при работе в окне «Контроля разводки», для удобства задания области элементов с одним номером.
ВНИМАНИЕ! Для совмещения разводки в точке с сохранением в базе такого вида разводки, используется функция
- «Лекало/ Совместить разводку в точке», а не данная экранная команда.
Чтобы произвольно переместить лекало (или группу совмещённых лекал) по экрану, необходимо:
Можно выполнить пункты меню «Окно/Экранные операции с лекалом/ Переместить лекало».
Для прекращения работы функции и отключения курсора нужно щелкнуть правой клавишей мышки.
Для Перемещения нескольких свободных лекал нужно:
Для Создания копии перемещаемого лекала необходимо:
создании смещаемой копии сохранит своё экранное положение (повороты, и т.п.).
Чтобы переместить лекало (или группу совмещённых лекал) по экрану на заданную величину, надо:
выполнить пункты текстового меню «Окно/Экранные операции с лекалом/ Переместить лекало на…»
Переключатель
становится активным, если указано лекало из группы совмещённых лекал. Отключив опцию, можно перемещать только одно указанное лекало группы лекал.
Например, можно создать новое лекало командой сборки (
- «Лекало/ Моделировать/ Собрать лекало»), расположив лекала группы на расстоянии друг от друга с помощью данной функции.
Симметричное лекало в системе может храниться в виде половинки, с надписью «Сгиб» на линии разворота. Чтобы вывести на экран для просмотра симметричное лекало в развернутом виде, нужно:
выполнить пункты меню «Окно/ Экранные операции с лекалом/ Развернуть симметричное лекало».
ВНИМАНИЕ!Функция служит лишь для просмотра на экране симметричного лекала вразворот.
На второй, развёрнутой части лекала не видны надсечки, эта половина лекала неактивна к работе.
Для полноценного разворота лекала в базе служит функция
-«Лекало/ Развернуть до целого».
Для того чтобы произвольно повернуть лекало (или группу совмещённых лекал) необходимо:
выполнить пункты меню «Окно/ Экранные операции с лекалом/ Повернуть лекало вокруг центра».
При этом лекало (или группа лекал) поворачивается на экране вокруг своего центра.
Для отличия лекал с экранным поворотом Точка подписи (
) выходит с повторной обводкой (
).
текстового меню «Окно/ Экранные операции с лекалом/ Возврат лекала в исходное состояние»
Для того чтобы повернуть лекало (или группу совмещённых лекал) вокруг точки, необходимо:
выполнить пункты меню «Окно/ Экранные операции с лекалом/ Повернуть лекало вокруг точки».
При этом лекало (или группа лекал) поворачиваются вокруг точки.
Для отличия лекал с экранным поворотом Точка подписи (
) выходит с повторной обводкой (
).
текстового меню «Окно/ Экранные операции с лекалом/ Возврат лекала в исходное состояние»
Чтобы повернуть только одно из совмещённых лекал, нужно
выполнять команду, нажав клавишу клавиатуры <CTRL>после выбора функции
.
Чтобы повернуть лекало (или группу совмещённых лекал) на экране на 90 градусов, необходимо:
Можно выполнить пункты меню «Окно/ Экранные операции с лекалом/ Повернуть лекало на 90 гр.»
Каждый новый щелчок курсора продолжает поворот лекал по часовой стрелке.
Для отличия лекал с экранным поворотом Точка подписи (
) выходит с повторной обводкой (
).
текстового меню «Окно/ Экранные операции с лекалом/ Возврат лекала в исходное состояние»
Для поворота лекала против часовой стрелки, выбирать функцию
нужно, одновременно удерживая клавишу клавиатуры <CTRL>
ВНИМАНИЕ! Для поворота лекала с пересортировкой в базе, служит команда
- «Лекало/ Пересортировать», а не данная экранная функция.
Чтобы отразить зеркально на экране лекало (или группу совмещённых лекал), необходимо:
Или выполнить пункты меню «Окно/ Экранные операции с лекалом/ Изобразить лекало зеркально»
При этом будет выполнен зеркальный поворот лекала или группы, согласно выбранного варианта.
На лекалах с экранным зеркальным отражением Точка подписи (
) выходит в виде эллипса (
).
Если лекало ещё и повёрнуто на экране, Точка надписи выходит в виде эллипса с обводкой (
).
Также можно повторно выполнить функцию
для этого лекала.
Группу совмещённых лекал можно вернуть в исходный вид, лишь повторно выполнив эту функцию.
Для зеркально повёрнутых на экране лекал работа функций (положительный
обход, и т.д.) ведётся согласно положению лекала на экране, а не в базе.
ВНИМАНИЕ! Для зеркального поворота лекала с пересортировкой в базе, служит команда
- «Лекало/ Пересортировать», а не данная экранная функция.
Чтобы перегнуть часть лекала (или группы совмещённых лекал) по линии перегиба, необходимо:
Или выполнить пункты текстового меню «Окно/ Экранные операции с лекалом/ Перегнуть лекало»
При этом указанная часть лекала поворачивается на экране вокруг линии перегиба.
ВНИМАНИЕ! Если линия перегиба фигурная (кривая), важно место щелчка на линии перегиба, ведь перегиб выполняется относительно касательной к линии перегиба в указанной точке.
Также можно повторно выполнить функцию
для этого лекала.
Группу совмещённых лекал можно вернуть в исходный вид, лишь повторно выполнив эту функцию.
Два дополнительных режима функции включаются при нажатии клавиши клавиатуры <CTRL> после выбора команды
:
Первое нажатие <CTRL>: Перегиб относительно касательной в конечной точке линии перегиба.
Для выполнения команды указывается участок возле конечной точки и перегибаемая часть лекала.
Этот вариант необходимо использовать для лекал с фигурной линией перегиба, так как здесь щелчок не в самом конце линии (в конечной точке), а рядом с ней ощутимо влияет на точность перегиба.
Второе нажатие <CTRL>: Выполнение перегиба по линии, заданной двумя точками на лекале. В этом случае указываются две точки, определяющие линию перегиба, и перегибаемая часть лекала.
1)Лекало в перегнутом состоянии невозможно перегнуть по другой линии.
2) На лекалах с Перегибом работают все команды, кроме некоторых функций: КОНТУР:
;
УЧАСТОК:
,
,
; ЛИНИИ:
,
; ТОЧКА:
; ШВЫ:
При этом на экран выходит сообщение:
3) При выполнении команды, указывать перегибаемую часть нужно как можно дальше от перегиба.
Иначе, на фигурной Линии перегиба касательная может выйти на вторую часть лекала, и перегнётся другая половина. Например, для перегиба лекала по стороне фигурной вытачки, можно указать перегибаемую часть на ОДНОМ И ТОМ ЖЕ УЧАСТКЕ так, что этот щелчок окажется то одной, то с другой стороны касательной, и в зависимости от этого будет выполнен перегиб разных частей.
Указывать перегибаемую часть как можно дальше от перегиба также необходимо, чтобы в разводке перегибаемая часть не оказалась в разных частях лекала.
4)Функция
- «Точка/ Сместить точку в точку» на лекалах в перегнутом виде может использоваться, например, для корректировки припуска подгиба низа.
При этом в качестве СМЕЩАЕМОЙ точки (2) всегда нужно указывать точку на перегнутой части.
(Неподвижная точка (1) найдена на пересечении бокового среза и эквидистанты от низа.
Ширина эквидистанты здесь равна величине двойного подгиба низа.)
После выполнения экранных поворотов
, перегиба
, симметричного разворота
, лекало можно вернуть в исходное состояние, согласно его положению в базе. Для этого необходимо:
При этом лекало возвращается в положение, в котором оно хранится в базе.
На совмещённых лекалах функция не работает. Сначала необходимо разрушить
группу лекал (кнопка
экранного меню), а затем выполнять функцию
.
Команды экранных совмещений позволяют создавать временные экранные группы лекал для проверки сопряжения и конфигураций линий между деталями и их частями. Кроме того, практически все функции программы отрабатывают не только на одном лекале, но и на группах совмещённых лекал.
Блок экранных совмещений лекал представлен командами
, а также
.
Чтобы совместить два лекала в одной точке, необходимо:
Можно выполнить пункты текстового меню «Окно/ Совместить лекала/ Совместить точки лекал»
При этом лекала совмещаются в одну точку (1), смещаясь без поворотов лекал.
Эта кнопка всегда активизируется при появлении на экране группы совмещения.
Чтобы совместить два лекала по участкам, необходимо:
Можно выполнить пункты текстового меню «Окно/ Совместить лекала/ Совместить участки лекал»
При этом участки совмещаются так, что точно совпадаёт только первая пара точек (1+2). Вторая неподвижная точка (3) лишь задаёт направление вдоль участка совмещения, и если длины совмещаемых участков разные, точки второй пары не совпадут (3 и 4)
Эта кнопка всегда активизируется при появлении на экране группы совмещения.
Чтобы совместить лекала по концам участков, необходимо:
Можно выполнить пункты меню «Окно/ Совместить лекала/ Совместить концы участков лекал»
При этом совмещаются концы участков по векторному направлению. На криволинейных участках линии совмещаются до тех пор, пока их конфигурация совпадает.
Эта кнопка всегда активизируется при появлении на экране группы совмещения.
Чтобы совместить лекала по концам участков на их продолжении, необходимо:
пункты меню «Окно/Совместить лекала/Совместить концы участков лекал на продолжении»
При этом линии перемещаемой группы совмещаются на продолжении неподвижной линии.
Эта кнопка всегда активизируется при появлении на экране группы совмещения.
После выполнения одной из команд совмещения
, лекала сцепляются по указанным линиям или точкам, объединяясь в так называемые группы. Можно совмещать группы между собой.
Долевые линии одной группы выделяются цветом, долевые разных групп окрашены разным цветом.
Для группы действуют и экранные команды (смещения, повороты, перегиб), и функции изменения лекал (моделирование, деформация, различные операции с лекалами и его элементами).
Для некоторых функций есть запрет, или ограничения при работе с группами совмещённых лекал, внесённые в описание порядка выполнения таких функций.
Для просмотра сопряжения группы лекал по всем размерам используются кнопки
на нижней панели рабочего окна. При необходимости, можно перейти в режим работы с 1 размером (переключатель
экранного меню) и корректировать кривизну линии (функции
,
- «Участок/ Произвольная деформация» и «Участок/ Сплайновая деформация участка»)
ВНИМАНИЕ! При совмещении лекал с неполной разводкой, ВСЕ команды работают только для общих существующих размеров, и на экран выходит список недостающих размеров.
Например, если поставить надсечку на лекале с полной разводкой, совмещённым с неполным, надсечка создаётся только в общих для группы размерах.
1) Команда «Организовать экран с учётом долевых» (
) с совмещёными лекалами не работает.
2) При выполнении функции «Организовать экран» (
), совмещённые лекала остаются в группах, не меняя место на экране. Свободные лекала будут организованы вокруг групп.
3) При выполнении функций
- «Лекало/ Сортировать долевой вертикально; горизонтально»
группы совмещённых лекал автоматически разрушаются.
4) При «разрезке» точки участка (
- «Участок/ Разделить участок) перед точкой Совмещения, группа разрушается.
5) Функции
- «Лекало/ Обтачка»,
- «Участок/ Установить угол между участками»
«Лекало/ Моделировать/ Развести лекало; и Развести лекало по линиям» с группами не работают.
Функция позволяет «перекатывать» (поочерёдно совмещать в указанных точках) участки одной группы вдоль участков другой группы, для проверки сопряжения различных узлов изделия.
Например, совместить лекала стана (первая группа) и рукавов (вторая группа), сложить эти группы в общей точке, и проворачивать рукав вдоль проймы, проверяя сопряжение по участкам втачивания.
Функция состоит из двух частей:
1)Задание параметров перекатывания: выбор неподвижной и перекатываемой линии;
2)Процесс перекатывания: Поочерёдное указание мест совмещения групп между собой.
Задание параметров перекатывания
Удерживая клавишу клавиатуры <SHIFT>, можно указать сразу несколько участков (1,2,3) ПО ЧАСОВОЙ СТРЕЛКЕ. При этом участки выделяются цветом (например, вся пройма).
Удерживая клавишу клавиатуры <SHIFT>, можно указать сразу несколько участков (4,5) ПО ЧАСОВОЙ СТРЕЛКЕ. При этом участки будут выделены цветом (например, весь окат)
- совпадение направления надсечек групп;
- противоположное направление надсечек групп.
Курсор принимает вид
(со стрелочкой), и можно выполнять вторую часть функции:
Указание места совмещения
поочерёдно. Перекатываемая линия будет укладываться на неё по касательной (насколько форма обоих линий может совпасть в указанной точке), с учётом расстояния от точки наложения групп.
Совпадающее направление надсечек
Противоположное направление надсечек
Если на экране несколько разных групп, необходимо указать любое лекало нужной группы.
1)При выполнении функции, удерживая клавишу клавиатуры <CTRL> перед выбором кнопки команды, можно сразу указывать места совмещения по заданным ранее линиям.
Например, можно указать неподвижную и перекатываемую линию, затем выполнить другие функции программы, и опять вернуться к «Перекатыванию», указывая только места стыковки линий.
2)При выполнении функции, задавать неподвижный и перекатываемый участки можно, удерживая клавишу клавиатуры <ALT>. В этом режиме, при указании одного участка подсвечиваются все участки на одной касательной с ним.
Например, указав один участок проймы, подсвечивается вся пройма на лекалах группы.
Чтобы удалить последнюю команду для группы (или нескольких групп) совмещённых лекал, нужно:
При этом автоматически срабатывает пошаговая отмена действий, производимых с группой (повороты, смещения, и т.п.) - до самой первой команды, пока кнопка не будет блокирована.
Для отмены последнего действия одной из групп необходимо указать лекало нужной группы.
Если на экране сначала совместить два лекала, затем с этой группой совместить третье лекало, последнее совмещение можно отменить с помощью данной функции
.
Лекала на экране положения не изменят, и свободное лекало нужно отодвинуть от группы вручную.
Чтобы разрушить группу (или несколько групп) совмещённых лекал, необходимо:
При этом группа автоматически разрушается, и кнопка будет заблокирована.
Для разрушения одной из групп необходимо указать нужную группу.
После разрушения на экране всех групп лекал, кнопки
и
блокируются.
Выполнение функции
, одновременно удерживая клавишу
клавиатуры <CTRL>, разрушает сразу все группы лекал.
В программе есть возможность создавать копий линий лекала - Групп линий, и работать с ними как с отдельными лекалами. Группы линий – это вторые экземпляры лекал, которые на экране видны не полностью. На экран выводятся только указанные линии, выбранные части лекал.
Действия, выполненные на группе линий, одновременно повторяются на лекале оригинала. Ведь группы линий– это участки вторых экземпляров лекал. Экземпляры, в отличие от безымянной копии, меняются на экране все одновременно, так как в базе – это одно лекало, с единым именем
Совмещая линии и оригиналы лекал между собой (кнопки
), можно работать, используя все функций программы. Группы линий можно использовать при моделировании (для сборки лекал, для нанесения модельных линий через временно закрытую вытачку). Также можно просмотреть и откорректировать вытачку в закрытом виде, и т.д.
Для экранного закрытия вытачки можно использовать и простые, безымянные копии лекал – но изменения на них не отображаются на оригинале, и процесс «Перестроения» не отработает.
Можно использовать также вторые экземпляры лекал (нажав кнопку экранного меню
, одновременно удерживая клавишу клавиатуры <CTRL>, или просто повторно вызвав лекало на экран).
Изменения на них параллельно отображаются на оригинале (и при этом отработает процесс «Перестроения»), но полная копия лекала выглядит при экранных совмещениях более громоздко, чем только нужные для работы линии.
Для того чтобы создать группу линий, необходимо:
Линии появляются на экране, выделяясь отдельным цветом. Порядок указания линий (часовая стрелка, и т. значения не имеет. Экранные повороты выбранных участков сохраняются и на линиях.
Каждая новая группа будет окрашена другим цветом.
После создания группы линий работать с ней можно, как с обычным лекалом: использовать функции экранных перемещений и совмещений, деформировать линии, наносить, смещать точки и контура.
1) Для групп линий используется цветовая настройка Лекала (Материалы)
(пункты «Настройки/ Параметры программы», закладка ЦВЕТОВАЯ ГАММА). Порядок вывода цветов на экран зависит от числа вызванных лекал и групп линий. Например, если на экране есть 2 лекала, группа вызывается в цвете №3.
Кроме того, работая в режиме «Цветовая гамма –Лекала» (пункты меню «Настройки/ Параметры программы», закладка ОБЩИЕ/ Конструктор), можно изменить на экране цвет линий, нажав кнопку
экранного меню и указав нужный цвет в окне выбора.
2) При копировании линий (
- «Лекало/ Копия») создаётся безымянная копия всего лекала.
3) В окне «Контроля разводки» видимость групп отключается
4) В группы выбирается любые типы контуров (в том числе и точечные, и Накол), кроме «Тени».
5) Если при создании линий указан участок ранее созданной группы, создаётся копия группы.
6) Группы линий выводятся на принтер или плоттер при прорисовке конструкторских лекал.
Для удаления линий с экрана, нужно выбрать кнопку экранного меню
- «Окно/ Убрать с экрана».
Команда
- «Окно/ Убрать лекало не сохраняя» удаляет и все линии группы, и сам оригинал.
Для отмены ошибочного выбора в ходе задания линий, нужно повторно указать тот же участок исходного лекала, но только в процессе выбора линий. После выполненного выбора невозможно исключить участок из группы
ВНИМАНИЕ! Нельзя использовать функцию удаления участка (
- «Участок/ удалить») ни для удаления линии, ни для отмены ошибочного выбора. Иначе удаляется участок на лекале оригинала
Для просмотра и корректировки вытачки в закрытом виде, необходимо:
- «Участок/ Произвольная деформация» и
- «Участок/ Сплайновая деформация участка»
При деформации на линиях одновременно деформируются и лекало - оригинал.
Используя группы линий можно наносить модельные линии через временно закрытые вытачки.
Например, на юбке нужно создать кокетку, закрыв две вытачки. Для этого необходимо:
Способы нанесения контуров на лекалах, совмещённых с группой линий
1)Если линия моделирования нужно временно (собрать лекало, и удалить модельную линию) –
её можно наносить, начиная с точки лекала-оригинала, и проводя по нужным точкам групп линий.
При удалении исходных модельных линий, процесс «Перестроения» выполнен не будет.
Поэтому для возможности «Перестроения» все модельные линии необходимо сохранять.
2) Если линия моделирования при создании должна автоматически перейти на оригинал уже в «развёрнутом» виде (то есть, с учётом временного закрытия вытачки, или другого совмещения лекала и линий), необходимо наносить произвольный контур в два приёма: сначала нанести часть контура на основном лекале, а затем на группе лекал.
Например, необходимо нанести модельные линии фигурной кокетки переднего полотнища юбки:
В окне параметров контура отключить опцию
, чтобы создалась только одна линия, на лекале.
Чтобы использовать её для дальнейшей сборки, её необходимо выбрать в новую группу (
), и совместить с лекалом и первой группой линий.
В отличие от первого варианта нанесения контура, модельные линии на лекале остаются в «развёрнутом» виде, для открытой вытачки.
Операция «Перестроения» будет работать, ведь такие модельные линии можно не удалять.
Когда на экране много визуальной информации, в ней сложно разобраться. Элементы лекала, выбираемые при выполнении функций, могут накладываться: контур может совпадать с другим контуром, в одну точку могут попадать точки разных контуров, и т.д. Для решения таких проблем можно отключать на экране видимость некоторых контуров, параметров, элементов и т.п.
Контур с отключённой видимостью не вычерчиваться при прорисовке на принтере или плоттере.
В экранном кнопочном меню есть ряд кнопок видимости и чувствительности элементов лекала:
На этих кнопках изображены все типы контуров лекала. Выбор кнопки с изображением контура отключает его видимость, повторный выбор этой кнопки – включает.
Выключение флажка под кнопкой позволяет отключить чувствительность данного типа контура. При этом контур на экране виден, но не восприимчив к действиям.
Обозначения кнопок видимости контуров:
- Рабочий срез
- Срез
- Готовый вид
- Внутренний контур
- Точка надписи
- Долевая
- Визир
- Текст
- Линия реза
- Прокол
- Тень
- Рисунок
- Режущие контура
Помимо контуров, можно отключить видимость на экране других компонентов лекала:
- точек (кроме надсечек),
- имени лекал,
- Параметры швов и построений (манжет, шлиц)
В программе возможны два режима работы блока видимости, в зависимости от выбора настройки
(пункты текстового меню «Настройки/ Параметры лекал», закладка ОБЩИЕ/ Конструктор»)
1) В режиме видимость линий «Экран», отключение выполняется сразу для всех лекал экрана, и выбранная кнопка блока выделяется, как-бы западая.
2) В режиме видимости «Лекало» включается переключатель над блоком:
- работа команд видимости/ чувствительности для всех лекал экрана
- работа команд видимости/ чувствительности для одного, указанного лекала на экране.
В данном режиме видимости выбранные кнопки не выделяются (ведь возможна работа с одним лекалом, а значит – для одних лекал кнопка должна быть выделена, для других - нет)
ВНИМАНИЕ! Не забудьте снова включить видимость элемента, чтобы дальше с ним работать.
Кнопка
отключает видимость контуров разных типов, для которых включён статус «Резать». Кнопка не имеет переключателя чувствительности и работает только для всего экрана (даже в режиме видимости «Лекало»).
Работа с экранными осями позволяет выполнять функции в повёрнутой и смещённой системе координат. При градации лекал можно задавать приращения в стандартных и повёрнутых координатах.
Кроме того, в работе часто возникает необходимость промеров на экране с помощью осей координат.
Кнопки работы с осями координат находятся в нижней части окна программы:
![]()
- вызов на экран и удаление осей координат
- установка начала координат
- поворот осей на произвольный угол
- поворот осей на заданный угол и возврат осей в нормальное положение.
Линии осей координат выходят на экран при выборе кнопки
нижней панели (или при выполнении пунктов текстового меню «Окно/ Оси координат/ Показать (убрать) оси координат»).
Если оси не видны, значит они за пределами видимой области экрана, и небходимо щёлкнуть в экран.
Повторный выбор данной функции
убирает оси с экрана.
Функция перемещения осей в точку срабатывает автоматически сразу после их вызова
.
Поэтому, достаточно сразу после вызова осей указать точку лекала.
Чтобы закрепить ось за другой точкой лекала, установив в ней начало координат, необходимо:
Чтобы повернуть ось координат (установив её, например, параллельно линии), необходимо:
Центр координат остаётся на месте, а ближняя из осей пройдёт через данную точку, поворачивая оси.
Можно после выбора функции указать ось, и удерживая нажатой левую клавишу мышки, вести курсор по экрану. Задав нужный поворот осей, можно отпустить клавишу мышки.
Если оси повернуть на экране, затем переставить центр координат в другую точку, при этом сохраняется угол поворота осей - но единый на все размеры, (такой, как в размере, вызванном на экран в момент выполнения функции)
Если на экране оси повёрнуты, кнопка поворота осей
имеет вид
(выделяется как «нажатая»). По окончании работы с осями эта кнопка должна быть выключена, поворот оси должен быть равен 0.
ВНИМАНИЕ! Необходимо следить, чтобы по окончании работы в повёрнутой системе координат ось была возвращена в стандартное положение. Иначе, даже при удалении с экрана видимости осей, функции будут выполняться в смещённой системе координат!
Чтобы вернуть ось в нормальное положение необходимо:
При этом будет установлен нулевой угол поворота, и ось возвращается в нормальное положение.
Чтобы уменьшить глубину вытачки, необходимо:
1)Вызвать на экран оси координат (
)
2)Установить начало координат в средней точке раствора (
)
3)Повернуть ось Х, проведя её через точку центра вытачки (
)
4)Сместить центральную точку вытачки вдоль оси Х (
- «Точка/ Сместить по Х»).
При этом точка смещается не по горизонтали, а вдоль повёрнутой оси Х.
5)Вернуть оси в нормальное положение, установив угол поворота осей равным 0 (
)
6)Убрать оси с экрана (
)
Работу с осями (поворот, смещение) можно выполнять с помощью колеса прокрутки мышки.
1) Установить оси в точке: Удерживая клавишу <CTRL>, щёлкнуть колесом мышки в точке.
2) Установить оси в конечной точке, по касательной к указанному месту участка: Удерживая клавишу <CTRL>, щёлкнуть колесом мышки РЯДОМ с конечной точкой
3) Повернуть оси: Удерживая клавишу <ALT>, щёлкнуть колесом мышки.
Таким образом, с помощью нажатого колеса мышки (в режиме <CTRL>) можно установить ось в конечной точке, либо по касательной к участку. В промежуточные точки ось так не устанавливается.
Возможность установить ось по касательной может использоваться при работе в «Таблице приращений» для градации лекала, задавая приращение вдоль нужного, в том числе криволинейного участка.
На нижней панели, рядом с функциями работы с осями находятся три окна координат курсора.
Подводя остриё курсора в нужное место лекала, можно просмотреть в ячейках слева направо: проекцию расстояния на ось Х, на ось У, и расстояние от острия курсора до центра экранных координат.
В программе есть ряд обслуживающих функций, используемых при выполнении различных команд.
С помощью кнопки
нижней панели можно очистить экран от цветовых выделений, которые появляются при выполнении функций, в ходе выбора для работы точек, участков, контуров и лекал.
Если при выполнении функции произведены некорректные действия, на экран выходит окно сообщения – информация об ошибке в работе, либо предупреждение пользователю, и т.д.
В программе есть два варианта вывода сообщений, в зависимости от выбора настройки
(пункты текстового меню «Настройки/ Параметры программы», закладки ОБЩИЕ/ Общие):
1)При работе с типом «Экран», сообщения сразу выводятся на середину рабочего экрана.
2)При работе с типом сообщения «Кнопка», команда информации (сообщений)
в экранном
кнопочном меню становится активной, только если при выполнении команды допущена ошибка, либо требуется вывести предупреждение пользователю.
При выборе кнопки, на экран выходит сообщение: по какой причине не выполняется функция, и т.п.:
Если пользователь опытный, и сам понимает ошибку, можно не нажимать эту кнопку, а продолжать работу в программе, выполняя функцию корректно.
Информационные сообщения можно убрать с экрана, нажав клавишу окна информации ДА, или с помощью кнопок клавиатуры ESC и ENTER (как и в диалоговых окнах команд)
При необходимости отключить чувствительность лекала (или группы лекал), можно включить режим запрета внесения изменений – «Запрещённый режим».
Для отключения чувствительности лекала на экране, необходимо:
Можно выполнить пункты текстового меню «Окно/ Запретить/разрешить изменения в лекале».
При этом лекало (или группа совмещённых лекал) окрашивается более тусклым цветом.
Работая на совмещённых лекалах, можно отключить только одно,
указанное лекало группы. Для этого нужно выполнять команду,
удерживая клавишу <CTRL> после выбора функции
.
По аналогии с «Унифицированными лекалами» (ссылочные лекала из других моделей), в «Запрещённые» лекала нельзя внести изменение, но с ними можно выполнять все экранные функции поворотов, смещений, можно выполнять промеры «Алгебры швов», и т.д.
Выбор цвета лекал в запрещённом режиме устанавливается в настройке программы «Цвета»
(пункты текстового меню «Настройки/ Параметры программы», закладка ЦВЕТОВАЯ ГАММА)
Команда позволяет выбирать нужный цвет лекал и Групп линий (кнопка
экранного меню).
Для выбора нового цвета лекала или группы линий, необходимо:
Можно также выполнить пункты текстового меню «Окно/ Задать цвет лекала».
При этом лекало принимает выбранный цвет, и окно выбора закрывается.
Кнопка выбора цветов
активна только при включении настройки Цветовая гамма в режиме «Лекала» (пункты меню «Настройка/ Параметры программы», закладка ОБШИЕ/ Конструктор»):
Набор и порядок следования цветов в окне выбора устанавливается в закладке ЦВЕТОВАЯ ГАММА окна настроек, в графе «Лекала (Материалы)»:
При выборе кнопки
в меню экранных функций, работа выбранной функции прекращается.
Данная кнопка становится активной при выборе функций программы.
Например, при выполнении сборки лекала (
- «Лекало/ Моделировать/ Собрать лекало»), при явно ошибочном указании участков можно прервать функцию, чтобы на экран не выходило заведомо некорректное лекало.
Если во время выполнения функции указывается ряд элементов, кнопка
позволяет произвести удаление выбранных элементов пошагово (один щелчок на кнопку – шаг назад).
После этого можно продолжать работу функции, указывая нужные элементы. То есть, не нужно прекращать выполнение основной функции.
Например, при выполнении сборки лекала (
- «Лекало/ Моделировать/ Собрать лекало»), при неверном выборе участка сборки, можно отменить ошибочно выбранный участок, и указать другой, не прекращая работу функции сборки.